6302 C# Programming Manual: D:/6302/C# Directory Reference

6302 C# Programming Manual
C# Directory Reference

Files

file | AIAdvanced.cs
file | AIChannel.cs
file | AIClock.cs
file | AIRecord.cs
file | AISignalExport.cs
file | AITrigger.cs
file | JY6302AITask.cs
Generated by doxygen 1.9.1


6302 C# Programming Manual: D:/6302/C#/AIAdvanced.cs File Reference

Classes | Namespaces
AIAdvanced.cs File Reference

Classes

class JY6302.AIAdvanced
Analog Input Advance Parameter Class More...

Namespaces

namespace JY6302


6302 C# Programming Manual: JY6302.AIAdvanced Class Reference

  • JY6302
  • AIAdvanced
List of all members
JY6302.AIAdvanced Class Reference

Analog Input Advance Parameter Class More...

Detailed Description

Analog Input Advance Parameter Class

The documentation for this class was generated from the following file:
  • D:/6302/C#/AIAdvanced.cs


6302 C# Programming Manual: D:/6302/C#/AIChannel.cs File Reference

Classes | Namespaces
AIChannel.cs File Reference

Classes

class JY6302.AIChannel
AI channel class. More...

Namespaces

namespace JY6302


6302 C# Programming Manual: JY6302.AIChannel Class Reference

  • JY6302
  • AIChannel
Public Member Functions | Properties | List of all members
JY6302.AIChannel Class Reference

AI channel class. More...

Public Member Functions

AIChannel (int channelId, ThermocoupleType thermocoupleType, double customizedCJTemperature)
Constructor. More...
AIChannel (int channelId, ThermocoupleType thermocoupleType, double rangeLow, double rangeHigh, double customizedCJTemperature)
Constructor. More...

Properties

int | ChannelID [get]
Channel ID More...
ThermocoupleType | ThemocoupleType [get]
Thermocouple type More...
double | CustomizedCJTemperature [get, set]
Customized cold junction (reference junction) temperature (℃) for compensation. More...
double | MaxVoltageRange [get]
Voltage range upper limit in V. More...

Detailed Description

AI channel class.

Constructor & Destructor Documentation

◆ AIChannel() [1/2]

JY6302.AIChannel.AIChannel | ( | int | channelId,
 |  | ThermocoupleType | thermocoupleType,
 |  | double | customizedCJTemperature
 | ) |  |

Constructor.

Parameters
channelId | Channel's physical ID
thermocoupleType | Thermocouple type
customizedCJTemperature | Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled and then take effect every time the ReadData method is called.

◆ AIChannel() [2/2]

JY6302.AIChannel.AIChannel | ( | int | channelId,
 |  | ThermocoupleType | thermocoupleType,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | customizedCJTemperature
 | ) |  |

Constructor.

Parameters
channelId | Channel's physical ID
thermocoupleType | Thermocouple type
rangeLow | Temperature range lower limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).
rangeHigh | Temperature range upper limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).

///

Parameters
customizedCJTemperature Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled and then take effect every time the ReadData method is called.

Property Documentation

◆ ChannelID

int JY6302.AIChannel.ChannelID
get

Channel ID

◆ CustomizedCJTemperature

double JY6302.AIChannel.CustomizedCJTemperature
getset

Customized cold junction (reference junction) temperature (℃) for compensation.

This parameter is only valid when buld-in cold-junction compensation disabled and then take effect every time the ReadData method is called.

◆ MaxVoltageRange

double JY6302.AIChannel.MaxVoltageRange
get

Voltage range upper limit in V.

◆ ThemocoupleType

ThermocoupleType JY6302.AIChannel.ThemocoupleType
get

Thermocouple type

The documentation for this class was generated from the following file:
  • D:/6302/C#/AIChannel.cs


6302 C# Programming Manual: D:/6302/C#/AIClock.cs File Reference

Classes | Namespaces | Enumerations
AIClock.cs File Reference

Classes

class | JY6302.AISampleClock
Sample clock configuration class More...
class | JY6302.AIExternalSampleClock
External Sample Clock Configuration Class More...

Namespaces

namespace JY6302

Enumerations

enum class JY6302.AISampleClockSource { JY6302.Internal = JY6302Import.JY6302_InternalSampleClock , JY6302.External = JY6302Import.JY6302_ExternalSampleClock }
AI Sample Clock Source More...
enum class JY6302.ClockTerminal {
JY6302.PFI0 = JY6302Import.JY6302_DigitalTriggerSource_PFI_0 , JY6302.PFI1 = JY6302Import.JY6302_DigitalTriggerSource_PFI_1 , JY6302.PFI2 = JY6302Import.JY6302_DigitalTriggerSource_PFI_2 , JY6302.PFI3 = JY6302Import.JY6302_DigitalTriggerSource_PFI_3 ,
JY6302.PXI_Trig0 = JY6302Import.JY6302_DigitalTriggerSource_BUS_0 , JY6302.PXI_Trig1 = JY6302Import.JY6302_DigitalTriggerSource_BUS_1 , JY6302.PXI_Trig2 = JY6302Import.JY6302_DigitalTriggerSource_BUS_2 , JY6302.PXI_Trig3 = JY6302Import.JY6302_DigitalTriggerSource_BUS_3 ,
JY6302.PXI_Trig4 = JY6302Import.JY6302_DigitalTriggerSource_BUS_4 , JY6302.PXI_Trig5 = JY6302Import.JY6302_DigitalTriggerSource_BUS_5 , JY6302.PXI_Trig6 = JY6302Import.JY6302_DigitalTriggerSource_BUS_6 , JY6302.PXI_Trig7 = JY6302Import.JY6302_DigitalTriggerSource_BUS_7 ,
JY6302.PXI_Star = JY6302Import.JY6302_DigitalTriggerSource_STAR
}
Clock Terminal More...


6302 C# Programming Manual: JY6302.AISampleClock Class Reference

  • JY6302
  • AISampleClock
Properties | List of all members
JY6302.AISampleClock Class Reference

Sample clock configuration class More...

Properties

AISampleClockSource | Source [get, set]
AI Sample Clock Source. More...
AIExternalSampleClock | External [get, set]
External Sample Clock Configuration. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

AIExternalSampleClock JY6302.AISampleClock.External
getset

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY6302.AISampleClock.Source
getset

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/6302/C#/AIClock.cs


6302 C# Programming Manual: JY6302.AIExternalSampleClock Class Reference

  • JY6302
  • AIExternalSampleClock
Properties | List of all members
JY6302.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY6302.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY6302.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • D:/6302/C#/AIClock.cs


6302 C# Programming Manual: D:/6302/C#/AIRecord.cs File Reference

Classes | Namespaces | Enumerations
AIRecord.cs File Reference

Classes

class JY6302.AIRecord
AI Record mode params. More...

Namespaces

namespace JY6302

Enumerations

enum class | JY6302.FileFormat { JY6302.Bin }
Streaming file format enum type. More...
enum class | JY6302.RecordMode { JY6302.Finite , JY6302.Infinite }
Record mode enum type. More...


6302 C# Programming Manual: JY6302.AIRecord Class Reference

  • JY6302
  • AIRecord
Properties | List of all members
JY6302.AIRecord Class Reference

AI Record mode params. More...

Properties

string | FilePath [get, set]
User specified file path (absolute path, including file name). More...
FileFormat | FileFormat [get]
Streaming file format. More...
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite. More...
double | Length [get, set]
User specified stream length in second. More...

Detailed Description

AI Record mode params.

Property Documentation

◆ FileFormat

FileFormat JY6302.AIRecord.FileFormat
get

Streaming file format.

◆ FilePath

string JY6302.AIRecord.FilePath
getset

User specified file path (absolute path, including file name).

◆ Length

double JY6302.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode.

◆ Mode

RecordMode JY6302.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/6302/C#/AIRecord.cs


6302 C# Programming Manual: D:/6302/C#/AISignalExport.cs File Reference

Classes | Namespaces
AISignalExport.cs File Reference

Classes

class JY6302.AISignalExport
AI Signal Export Class More...

Namespaces

namespace JY6302


6302 C# Programming Manual: JY6302.AISignalExport Class Reference

  • JY6302
  • AISignalExport
Public Member Functions | List of all members
JY6302.AISignalExport Class Reference

AI Signal Export Class More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

AI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY6302.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY6302.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY6302.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY6302.AISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/6302/C#/AISignalExport.cs


6302 C# Programming Manual: D:/6302/C#/AITrigger.cs File Reference

Classes | Namespaces | Enumerations
AITrigger.cs File Reference

Classes

class | JY6302.AIDigitalTrigger
AI Digital trigger params. More...
class | JY6302.AITrigger
AI Trigger params More...

Namespaces

namespace JY6302

Enumerations

enum class | JY6302.AITriggerMode { JY6302.Start , JY6302.Reference }
AI trigger mode enum type. More...
enum class JY6302.AIDigitalTriggerSource {
JY6302.PFI0 = JY6302Import.JY6302_DigitalTriggerSource_PFI_0 , JY6302.PFI1 = JY6302Import.JY6302_DigitalTriggerSource_PFI_1 , JY6302.PFI2 = JY6302Import.JY6302_DigitalTriggerSource_PFI_2 , JY6302.PFI3 = JY6302Import.JY6302_DigitalTriggerSource_PFI_3 ,
JY6302.PXI_Trig0 = JY6302Import.JY6302_DigitalTriggerSource_BUS_0 , JY6302.PXI_Trig1 = JY6302Import.JY6302_DigitalTriggerSource_BUS_1 , JY6302.PXI_Trig2 = JY6302Import.JY6302_DigitalTriggerSource_BUS_2 , JY6302.PXI_Trig3 = JY6302Import.JY6302_DigitalTriggerSource_BUS_3 ,
JY6302.PXI_Trig4 = JY6302Import.JY6302_DigitalTriggerSource_BUS_4 , JY6302.PXI_Trig5 = JY6302Import.JY6302_DigitalTriggerSource_BUS_5 , JY6302.PXI_Trig6 = JY6302Import.JY6302_DigitalTriggerSource_BUS_6 , JY6302.PXI_Trig7 = JY6302Import.JY6302_DigitalTriggerSource_BUS_7 ,
JY6302.PXI_Star = JY6302Import.JY6302_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | JY6302.AITriggerType { JY6302.Immediately = JY6302Import.JY6302_TriggerType_Immediately , JY6302.Digital = JY6302Import.JY6302_TriggerType_Digital , JY6302.Soft = JY6302Import.JY6302_TriggerType_Soft }
AI trigger type enum type. More...
enum class | JY6302.AIDigitalTriggerEdge { JY6302.Rising = JY6302Import.JY6302_DigitalTriggerEdge_Rising , JY6302.Falling = JY6302Import.JY6302_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...


6302 C# Programming Manual: JY6302.AIDigitalTrigger Class Reference

  • JY6302
  • AIDigitalTrigger
Properties | List of all members
JY6302.AIDigitalTrigger Class Reference

AI Digital trigger params. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI digital trigger source. More...
AIDigitalTriggerEdge | Edge [get, set]
AI digital trigger effective edge. More...

Detailed Description

AI Digital trigger params.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY6302.AIDigitalTrigger.Edge
getset

AI digital trigger effective edge.

◆ Source

AIDigitalTriggerSource JY6302.AIDigitalTrigger.Source
getset

AI digital trigger source.

The documentation for this class was generated from the following file:
  • D:/6302/C#/AITrigger.cs


6302 C# Programming Manual: JY6302.AITrigger Class Reference

  • JY6302
  • AITrigger
Properties | List of all members
JY6302.AITrigger Class Reference

AI Trigger params More...

Properties

AITriggerType | Type [get, set]
AI trigger type. More...
AITriggerMode | Mode [get, set]
AI trigger mode. More...
AIDigitalTrigger | Digital [get]
AI digital trigger params. More...
uint | ReTriggerCount [get, set]
Number of repeat triggers. More...
uint | PreTriggerSamples [get, set]
AI pretrigger points. More...

Detailed Description

AI Trigger params

Property Documentation

◆ Digital

AIDigitalTrigger JY6302.AITrigger.Digital
get

AI digital trigger params.

◆ Mode

AITriggerMode JY6302.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY6302.AITrigger.PreTriggerSamples
getset

AI pretrigger points.

Only valid in the reference trigger mode.

◆ ReTriggerCount

uint JY6302.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

No repeat the trigger when 0 or 1, or the number of repeated triggers.

◆ Type

AITriggerType JY6302.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/6302/C#/AITrigger.cs


6302 C# Programming Manual: D:/6302/C#/JY6302AITask.cs File Reference

Classes | Namespaces | Enumerations
JY6302AITask.cs File Reference

Classes

class JY6302.JY6302AITask
JY6302 AI task class which applies to temperature measurements using the Type R/S/B/J/T/E/K/N/C/A thermocouple(max input voltage +-78.125mV). More...

Namespaces

namespace JY6302

Enumerations

enum class | JY6302.AIMode { JY6302.Finite = JY6302Import.JY6302_AI_Finite , JY6302.Continuous = JY6302Import.JY6302_AI_Continuous , JY6302.Single = JY6302Import.JY6302_AI_Single , JY6302.Record = 3 }
AI mode enum type. More...
enum class | JY6302.ThermocoupleConnectionStatus { JY6302.Normal , JY6302.OpenCircuit , JY6302.ShortCircuit }
Thermocouple connection status More...
enum class | JY6302.BurnoutCurrentValue { JY6302._0p5uA = 1 , JY6302._2uA = 2 , JY6302._4uA = 3 }
Burnout current value selection for open thermocouple detection More...


6302 C# Programming Manual: JY6302.JY6302AITask Class Reference

  • JY6302
  • JY6302AITask
Public Member Functions | Properties | List of all members
JY6302.JY6302AITask Class Reference

JY6302 AI task class which applies to temperature measurements using the Type R/S/B/J/T/E/K/N/C/A thermocouple(max input voltage +-78.125mV). More...

Public Member Functions

JY6302AITask (int boardNum)
Constructor. More...
JY6302AITask (string boardName)
Constructor. More...
void | AddChannel (int chnID, ThermocoupleType thermocoupleType, double customizedCJTemperature=0)
Add one/all channel(s), and automatically determine the input voltage range based on the type of thermocouple. More...
void | AddChannel (int chnID, ThermocoupleType thermocoupleType, double rangeLow, double rangeHigh, double customizedCJTemperature=0)
Add one/all channel(s), and manually specify the temperature range. More...
void | AddChannel (int[] chnID, ThermocoupleType thermocoupleType, double customizedCJTemperature=0)
Add a group channels, and automatically determine the input voltage range based on the type of thermocouple. More...
void | AddChannel (int[] chnID, ThermocoupleType thermocoupleType, double rangeLow, double rangeHigh, double customizedCJTemperature=0)
Add a group channels, and manually specify the temperature range. More...
void | AddChannel (int[] chnID, ThermocoupleType[] thermocoupleType, double[] customizedCJTemperature)
Add a group channels, and automatically determine the input voltage range based on the type of thermocouple. More...
void | AddChannel (int[] chnID, ThermocoupleType[] thermocoupleType, double[] rangeLow, double[] rangeHigh, double[] customizedCJTemperature)
Add a group channels, and manually specify the temperature range. More...
void | RemoveChannel (int chnID)
Delete the channel with the specified channel ID. More...
void | SetCJTemperature (int chnID, double temperature)
Set cold junction (reference junction) temperature with a specified channel ID. More...
void | SetCJTemperature (double[] temperature)
Set cold junction (reference junction) temperature to all channels that has been added. More...
void | ReportBuildInCJException ()
Query connection status of the cold-junction terminal TB68CJ(s), if the necessary TB68CJ(s) is detected to be offline, an exception will be thrown. More...
void | ReadRawData (ref double[] EMFBuf, ref double[] coldJunctionTemperatureBuf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data and store it in buffer. More...
void | ReadRawData (ref double[] EMFBuf, ref double[] coldJunctionTemperatureBuf, int timeout=-1)
Read one or multi-channel raw data and store it in buffer. More...
void | ReadRawData (ref double[,] EMFBuf, ref double[,] coldJunctionTemperatureBuf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data by columns and store it in a data buffer. More...
void | ReadRawData (ref double[,] EMFBuf, ref double[,] coldJunctionTemperatureBuf, int timeout)
Read one or multi-channel raw data by columns and store it in a data buffer. More...
void | ReadRawData (IntPtr EMFBuf, IntPtr coldJunctionTemperatureBuf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data and store it in unmanaged memory pointer. More...
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout)
Read one or multi-channel data and store it in a data buffer. More...
void | ReadData (ref double[] buf, int timeout=-1)
Read one or multi-channel data and store it in a data buffer. More...
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout)
Read one or multi-channel data by columns and store it in a data buffer. More...
void | ReadData (ref double[,] buf, int timeout=-1)
Read one or multi-channel data by columns and store it in a data buffer. More...
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel data and store it in a unmannaged data buffer. More...
void | ReadSinglePoint (ref double[] buf)
Read one sample (per channel) in unbuffered reading. More...
void | ReadSinglePoint (IntPtr buf)
Read one sample (per channel) in unbuffered reading to unmannaged buffer. More...
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout)
Preview two dimentional data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[,] buf, int timeout=-1)
Preview two dimentional data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout)
Preview data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int timeout=-1)
Preview data when streaming is in progress. More...
void | GetRecordStatus (out ulong recordedLength, out bool recordDone)
Get the streaming status. More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...
Dictionary< int, ThermocoupleConnectionStatus > | DetectOpenThermocouple (BurnoutCurrentValue currentValue=BurnoutCurrentValue._0p5uA)
Perform open thermocouple detection (OTD) to determine if there are any enabled channels do not have a thermocouple connectecd to the module. More...
void | Start ()
Start AI task. More...
void | Stop ()
Stop AI task. More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...

Properties

JY6302Device | Device [get]
The device instance called by this AI task instance. More...
PowerLineRejection | PowerLineRejection [get]
Power line rejection configuration. More...
BuildInCJC | BuildInCJC [get]
Build-In Cold(Reference)-Junction Compensation Configuration More...
AIMode | Mode [get, set]
Sample Mode. More...
double | MaxSampleRate [get]
The maximum total sample rate at the current timing mode. More...
double | SampleRate [get, set]
Sampling rate per channel (S/s). More...
int | SamplesToAcquire [get, set]
Number of samples to acquire per channel. More...
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer. More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
AISampleClock | SampleClock [get]
Sample Clock Configuration More...
AITrigger | Trigger [get]
Trigger Configuration More...
List< AIChannel > | Channels [get]
List of enabled channels More...
AIRecord | Record [get]
Record Mode Configuration More...
AISignalExport | SignalExport [get]
Signal Export Configuration More...
AIAdvanced | Advanced [get]
Advanced Configuration More...
bool | NonTCSignalMeasEnabled [get, set]
Non-thermocouple voltage signal measurement enable. More...

Detailed Description

JY6302 AI task class which applies to temperature measurements using the Type R/S/B/J/T/E/K/N/C/A thermocouple(max input voltage +-78.125mV).

Constructor & Destructor Documentation

◆ JY6302AITask() [1/2]

JY6302.JY6302AITask.JY6302AITask ( int boardNum )

Constructor.

Used to create an AI task object by board number.

Parameters
boardNum The slot number where the board is located, the first board will be opened when 0 is given.

◆ JY6302AITask() [2/2]

JY6302.JY6302AITask.JY6302AITask ( string boardName )

Constructor.

Used to create an AI task object by board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/6]

void JY6302.JY6302AITask.AddChannel | ( | int | chnID,
 |  | ThermocoupleType | thermocoupleType,
 |  | double | customizedCJTemperature = 0
 | ) |  |

Add one/all channel(s), and automatically determine the input voltage range based on the type of thermocouple.

Parameters
chnID | Channel's physical number. chnId = -1: add all channels.
thermocoupleType | The type of thermocouple connected to this channel.
customizedCJTemperature | Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

◆ AddChannel() [2/6]

void JY6302.JY6302AITask.AddChannel | ( | int | chnID,
 |  | ThermocoupleType | thermocoupleType,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | customizedCJTemperature = 0
 | ) |  |

Add one/all channel(s), and manually specify the temperature range.

Parameters
chnID | Channel's physical ID. chnId = -1: add all channels.
thermocoupleType | The type of thermocouple connected to this channel.
rangeLow | Temperature range lower limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).
rangeHigh | Temperature range upper limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).
customizedCJTemperature | Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

◆ AddChannel() [3/6]

void JY6302.JY6302AITask.AddChannel | ( | int[] | chnID,
 |  | ThermocoupleType | thermocoupleType,
 |  | double | customizedCJTemperature = 0
 | ) |  |

Add a group channels, and automatically determine the input voltage range based on the type of thermocouple.

Parameters
chnID | A group of channel physical IDs.
thermocoupleType | The type of thermocouple connected to this channel.
customizedCJTemperature | Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

◆ AddChannel() [4/6]

void JY6302.JY6302AITask.AddChannel | ( | int[] | chnID,
 |  | ThermocoupleType | thermocoupleType,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | customizedCJTemperature = 0
 | ) |  |

Add a group channels, and manually specify the temperature range.

Parameters
chnID | A group of channel physical IDs.
thermocoupleType | The type of thermocouple connected to this channel.
rangeLow | Temperature range lower limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).
rangeHigh | Temperature range upper limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).
customizedCJTemperature | Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

◆ AddChannel() [5/6]

void JY6302.JY6302AITask.AddChannel | ( | int[] | chnID,
 |  | ThermocoupleType[] | thermocoupleType,
 |  | double[] | customizedCJTemperature
 | ) |  |

Add a group channels, and automatically determine the input voltage range based on the type of thermocouple.

Parameters
chnID | A group of channel physical IDs.
thermocoupleType | The type of thermocouple connected to this channel.
customizedCJTemperature | Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

◆ AddChannel() [6/6]

void JY6302.JY6302AITask.AddChannel | ( | int[] | chnID,
 |  | ThermocoupleType[] | thermocoupleType,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | double[] | customizedCJTemperature
 | ) |  |

Add a group channels, and manually specify the temperature range.

Parameters
chnID | A group of channel physical IDs.
thermocoupleType | The type of thermocouple connected to this channel.
rangeLow | Temperature range lower limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).
rangeHigh | Temperature range upper limit in ℃ ( assume cold-junction (reference-junction) temperature is 0℃ ).
customizedCJTemperature | Customized cold junction (reference junction) temperature (℃) for compensation. This parameter is only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

◆ DetectOpenThermocouple()

Dictionary<int, ThermocoupleConnectionStatus> JY6302.JY6302AITask.DetectOpenThermocouple ( BurnoutCurrentValue currentValue = BurnoutCurrentValue._0p5uA )

Perform open thermocouple detection (OTD) to determine if there are any enabled channels do not have a thermocouple connectecd to the module.

Parameters
currentValue Burnout current value.
Returns
OTD result. Dictionary's key: channel physical ID; value: thermocouple connection status.

◆ GetRecordPreviewData() [1/4]

void JY6302.JY6302AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Preview two dimentional data when streaming is in progress.

Each column represents one channel. This method will return the value of temperature in ℃.

Parameters
buf | User specified buffer for preview data.
samplesPerChannel | Number of preview samples per channel.
timeout | Timeout in ms before generate exception, timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/4]

void JY6302.JY6302AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = -1
 | ) |  |

Preview two dimentional data when streaming is in progress.

Each column represents one channel. This method will return the value of temperature in ℃.

Parameters
buf | User specified buffer for preview data.
timeout | Timeout in ms before generate exception, timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [3/4]

void JY6302.JY6302AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Preview data when streaming is in progress.

This method will return the value of temperature in ℃.

Parameters
buf | User specified buffer for preview data.
samplesPerChannel | Number of preview samples per channel.
timeout | Timeout in ms before generate exception, timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [4/4]

void JY6302.JY6302AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = -1
 | ) |  |

Preview data when streaming is in progress.

Each column represents one channel. This method will return the value of temperature in ℃.

Parameters
buf | User specified buffer for preview data.
timeout | Timeout in ms before generate exception, timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JY6302.JY6302AITask.GetRecordStatus | ( | out ulong | recordedLength,
 |  | out bool | recordDone
 | ) |  |

Get the streaming status.

Parameters
recordedLength | Length of the streamed samples per channel.
recordDone | Wether the streaming is over.

◆ ReadData() [1/5]

void JY6302.JY6302AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read one or multi-channel data and store it in a unmannaged data buffer.

This method will return the value of temperature in ℃.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JY6302.JY6302AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read one or multi-channel data by columns and store it in a data buffer.

This method will return the value of temperature in ℃.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate exception, timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JY6302.JY6302AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = -1
 | ) |  |

Read one or multi-channel data by columns and store it in a data buffer.

This method will return the value of temperature in ℃.

Parameters
buf | Data buffer.
timeout | Timeout in ms before generate exception, timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JY6302.JY6302AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read one or multi-channel data and store it in a data buffer.

This method will return the value of temperature in ℃.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JY6302.JY6302AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = -1
 | ) |  |

Read one or multi-channel data and store it in a data buffer.

This method will return the value of temperature in ℃.

Parameters
buf | Data buffer.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/5]

void JY6302.JY6302AITask.ReadRawData | ( | IntPtr | EMFBuf,
 |  | IntPtr | coldJunctionTemperatureBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read one or multi-channel raw data and store it in unmanaged memory pointer.

This method will copy the data of the hot(measuring) junction and the cold(reference) junction to user buffer respectively. Both arrays must have the same size. The ordering of the data in the two arrays is consistent.

Parameters
EMFBuf | User buffer used to read measured electromotive force. Unit: V.
coldJunctionTemperatureBuf | User buffer used to read measured cold(reference) junction temperature. Unit: ℃.
samplesPerChannel | Number of samples per channel
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/5]

void JY6302.JY6302AITask.ReadRawData | ( | ref double | EMFBuf[,],
 |  | ref double | coldJunctionTemperatureBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read one or multi-channel raw data by columns and store it in a data buffer.

This method will copy the data of the hot(measuring) junction and the cold(reference) junction to user buffer respectively. Both arrays must have the same size. The ordering of the data in the two arrays is consistent.

Parameters
EMFBuf | User buffer used to read measured electromotive force. Unit: V.
coldJunctionTemperatureBuf | User buffer used to read measured cold(reference) junction temperature. Unit: ℃.
samplesPerChannel | Number of samples per channel
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/5]

void JY6302.JY6302AITask.ReadRawData | ( | ref double | EMFBuf[,],
 |  | ref double | coldJunctionTemperatureBuf[,],
 |  | int | timeout
 | ) |  |

Read one or multi-channel raw data by columns and store it in a data buffer.

This method will copy the data of the measuring junction and the reference junction to user buffer respectively. Both arrays must have the same size. The ordering of the data in the two arrays is consistent.

Parameters
EMFBuf | User buffer used to read measured electromotive force. Unit: V.
coldJunctionTemperatureBuf | User buffer used to read measured cold(reference) junction temperature. Unit: ℃.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [4/5]

void JY6302.JY6302AITask.ReadRawData | ( | ref double[] | EMFBuf,
 |  | ref double[] | coldJunctionTemperatureBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout
 | ) |  |

Read one or multi-channel raw data and store it in buffer.

This method will copy the data of the hot(measuring) junction and the cold(reference) junction to user buffer respectively. Both arrays must have the same size. The ordering of the data in the two arrays is consistent.

Parameters
EMFBuf | User buffer used to read measured electromotive force. Unit: V.
coldJunctionTemperatureBuf | User buffer used to read measured cold(reference) junction temperature. Unit: ℃.
samplesPerChannel | Number of samples per channel
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [5/5]

void JY6302.JY6302AITask.ReadRawData | ( | ref double[] | EMFBuf,
 |  | ref double[] | coldJunctionTemperatureBuf,
 |  | int | timeout = -1
 | ) |  |

Read one or multi-channel raw data and store it in buffer.

This method will copy the data of the hot(measuring) junction and the cold(reference) junction to user buffer respectively. Both arrays must have the same size. The ordering of the data in the two arrays is consistent.

Parameters
EMFBuf | User buffer used to read measured electromotive force. Unit: V.
coldJunctionTemperatureBuf | User buffer used to read measured cold(reference) junction temperature. Unit: ℃.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY6302.JY6302AITask.ReadSinglePoint ( IntPtr buf )

Read one sample (per channel) in unbuffered reading to unmannaged buffer.

This method will return the value of temperature in ℃.

Parameters
buf Data buffer.

◆ ReadSinglePoint() [2/2]

void JY6302.JY6302AITask.ReadSinglePoint ( ref double[] buf )

Read one sample (per channel) in unbuffered reading.

This method will return the value of temperature in ℃.

Parameters
buf Data buffer.

◆ RemoveChannel()

void JY6302.JY6302AITask.RemoveChannel ( int chnID )

Delete the channel with the specified channel ID.

Parameters
chnID Specified channel ID. chnId = -1: remove all channels.

◆ ReportBuildInCJException()

void JY6302.JY6302AITask.ReportBuildInCJException ( )

Query connection status of the cold-junction terminal TB68CJ(s), if the necessary TB68CJ(s) is detected to be offline, an exception will be thrown.

The threshold that is considered offline can be adjusted by property TerminalBlock.UpdateTimeout in JY6302Device.TerminalBlock.

◆ SendSoftwareTrigger()

void JY6302.JY6302AITask.SendSoftwareTrigger ( )

Generate a software trigger.

Returns

◆ SetCJTemperature() [1/2]

void JY6302.JY6302AITask.SetCJTemperature ( double[] temperature )

Set cold junction (reference junction) temperature to all channels that has been added.

These parameter are only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

Parameters
temperature Cold junction (reference juntion) temperature in ℃. The ordering of the elements must be the same as the order in which the channels are added.

◆ SetCJTemperature() [2/2]

void JY6302.JY6302AITask.SetCJTemperature | ( | int | chnID,
 |  | double | temperature
 | ) |  |

Set cold junction (reference junction) temperature with a specified channel ID.

These parameter are only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

Parameters
chnID | Specified channel ID, this channle must already has been added. chnId = -1: set this temperature to all channels that has been added.
temperature | Cold junction (reference juntion) temperature in ℃.

◆ Start()

void JY6302.JY6302AITask.Start ( )

Start AI task.

◆ Stop()

void JY6302.JY6302AITask.Stop ( )

Stop AI task.

◆ WaitUntilDone()

bool JY6302.JY6302AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Only valid when Mode is AIMode.Finite.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS.
Returns
Whether the task has been completed

Property Documentation

◆ Advanced

AIAdvanced JY6302.JY6302AITask.Advanced
get

Advanced Configuration

◆ AvailableSamples

ulong JY6302.JY6302AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BuildInCJC

BuildInCJC JY6302.JY6302AITask.BuildInCJC
get

Build-In Cold(Reference)-Junction Compensation Configuration

◆ Channels

List<AIChannel> JY6302.JY6302AITask.Channels
get

List of enabled channels

◆ Device

JY6302Device JY6302.JY6302AITask.Device
get

The device instance called by this AI task instance.

◆ MaxSampleRate

double JY6302.JY6302AITask.MaxSampleRate
get

The maximum total sample rate at the current timing mode.

◆ Mode

AIMode JY6302.JY6302AITask.Mode
getset

Sample Mode.

◆ NonTCSignalMeasEnabled

bool JY6302.JY6302AITask.NonTCSignalMeasEnabled
getset

Non-thermocouple voltage signal measurement enable.

When enabled, the bias voltage on all channels will be disabled. At this time, only the voltage value read by method JY6302AITask.ReadRawData() is accurate.

◆ PowerLineRejection

PowerLineRejection JY6302.JY6302AITask.PowerLineRejection
get

Power line rejection configuration.

6302 can reject 50Hz or 60Hz components when the TOTAL sampling rate is less than or equal to 40Sa/s.

◆ Record

AIRecord JY6302.JY6302AITask.Record
get

Record Mode Configuration

◆ SampleClock

AISampleClock JY6302.JY6302AITask.SampleClock
get

Sample Clock Configuration

◆ SampleRate

double JY6302.JY6302AITask.SampleRate
getset

Sampling rate per channel (S/s).

The minimum is 0.275S/s and the maximum is 800S/s. The actual sample rate is subject to the the number of channels, and the rounding operation. You can read this property to obtain the sampling rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY6302.JY6302AITask.SamplesToAcquire
getset

Number of samples to acquire per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY6302.JY6302AITask.SignalExport
get

Signal Export Configuration

◆ TransferedSamples

ulong JY6302.JY6302AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger JY6302.JY6302AITask.Trigger
get

Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/6302/C#/JY6302AITask.cs


6302 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY6302 |
C AIAdvanced | Analog Input Advance Parameter Class
C AIChannel | AI channel class
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AIRecord | AI Record mode params
C AISignalExport | AI Signal Export Class
C AIDigitalTrigger | AI Digital trigger params
C AITrigger | AI Trigger params
C JY6302AITask | JY6302 AI task class which applies to temperature measurements using the Type R/S/B/J/T/E/K/N/C/A thermocouple(max input voltage +-78.125mV)


6302 C# Programming Manual: Member List

  • JY6302
  • AIAdvanced
JY6302.AIAdvanced Member List

This is the complete list of members for JY6302.AIAdvanced, including all inherited members.


6302 C# Programming Manual: Member List

  • JY6302
  • AIChannel
JY6302.AIChannel Member List

This is the complete list of members for JY6302.AIChannel, including all inherited members.

AIChannel(int channelId, ThermocoupleType thermocoupleType, double customizedCJTemperature) | JY6302.AIChannel
AIChannel(int channelId, ThermocoupleType thermocoupleType, double rangeLow, double rangeHigh, double customizedCJTemperature) | JY6302.AIChannel
ChannelID | JY6302.AIChannel
CustomizedCJTemperature | JY6302.AIChannel
MaxVoltageRange | JY6302.AIChannel
ThemocoupleType | JY6302.AIChannel


6302 C# Programming Manual: Member List

  • JY6302
  • AIDigitalTrigger
JY6302.AIDigitalTrigger Member List

This is the complete list of members for JY6302.AIDigitalTrigger, including all inherited members.

Edge | JY6302.AIDigitalTrigger
Source | JY6302.AIDigitalTrigger


6302 C# Programming Manual: Member List

  • JY6302
  • AIExternalSampleClock
JY6302.AIExternalSampleClock Member List

This is the complete list of members for JY6302.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY6302.AIExternalSampleClock
Terminal | JY6302.AIExternalSampleClock


6302 C# Programming Manual: Member List

  • JY6302
  • AIRecord
JY6302.AIRecord Member List

This is the complete list of members for JY6302.AIRecord, including all inherited members.

FileFormat | JY6302.AIRecord
FilePath | JY6302.AIRecord
Length | JY6302.AIRecord
Mode | JY6302.AIRecord


6302 C# Programming Manual: Member List

  • JY6302
  • AISampleClock
JY6302.AISampleClock Member List

This is the complete list of members for JY6302.AISampleClock, including all inherited members.

External | JY6302.AISampleClock
Source | JY6302.AISampleClock


6302 C# Programming Manual: Member List

  • JY6302
  • AISignalExport
JY6302.AISignalExport Member List

This is the complete list of members for JY6302.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY6302.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY6302.AISignalExport
Clear(SignalExportDestination destination) | JY6302.AISignalExport
ClearAll() | JY6302.AISignalExport


6302 C# Programming Manual: Member List

  • JY6302
  • AITrigger
JY6302.AITrigger Member List

This is the complete list of members for JY6302.AITrigger, including all inherited members.

Digital | JY6302.AITrigger
Mode | JY6302.AITrigger
PreTriggerSamples | JY6302.AITrigger
ReTriggerCount | JY6302.AITrigger
Type | JY6302.AITrigger


6302 C# Programming Manual: Member List

  • JY6302
  • JY6302AITask
JY6302.JY6302AITask Member List

This is the complete list of members for JY6302.JY6302AITask, including all inherited members.

AddChannel(int chnID, ThermocoupleType thermocoupleType, double customizedCJTemperature=0) | JY6302.JY6302AITask
AddChannel(int chnID, ThermocoupleType thermocoupleType, double rangeLow, double rangeHigh, double customizedCJTemperature=0) | JY6302.JY6302AITask
AddChannel(int[] chnID, ThermocoupleType thermocoupleType, double customizedCJTemperature=0) | JY6302.JY6302AITask
AddChannel(int[] chnID, ThermocoupleType thermocoupleType, double rangeLow, double rangeHigh, double customizedCJTemperature=0) | JY6302.JY6302AITask
AddChannel(int[] chnID, ThermocoupleType[] thermocoupleType, double[] customizedCJTemperature) | JY6302.JY6302AITask
AddChannel(int[] chnID, ThermocoupleType[] thermocoupleType, double[] rangeLow, double[] rangeHigh, double[] customizedCJTemperature) | JY6302.JY6302AITask
Advanced | JY6302.JY6302AITask
AvailableSamples | JY6302.JY6302AITask
BuildInCJC | JY6302.JY6302AITask
Channels | JY6302.JY6302AITask
DetectOpenThermocouple(BurnoutCurrentValue currentValue=BurnoutCurrentValue._0p5uA) | JY6302.JY6302AITask
Device | JY6302.JY6302AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
GetRecordPreviewData(ref double[,] buf, int timeout=-1) | JY6302.JY6302AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
GetRecordPreviewData(ref double[] buf, int timeout=-1) | JY6302.JY6302AITask
GetRecordStatus(out ulong recordedLength, out bool recordDone) | JY6302.JY6302AITask
JY6302AITask(int boardNum) | JY6302.JY6302AITask
JY6302AITask(string boardName) | JY6302.JY6302AITask
MaxSampleRate | JY6302.JY6302AITask
Mode | JY6302.JY6302AITask
NonTCSignalMeasEnabled | JY6302.JY6302AITask
PowerLineRejection | JY6302.JY6302AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
ReadData(ref double[] buf, int timeout=-1) | JY6302.JY6302AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
ReadData(ref double[,] buf, int timeout=-1) | JY6302.JY6302AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
ReadRawData(ref double[] EMFBuf, ref double[] coldJunctionTemperatureBuf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
ReadRawData(ref double[] EMFBuf, ref double[] coldJunctionTemperatureBuf, int timeout=-1) | JY6302.JY6302AITask
ReadRawData(ref double[,] EMFBuf, ref double[,] coldJunctionTemperatureBuf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
ReadRawData(ref double[,] EMFBuf, ref double[,] coldJunctionTemperatureBuf, int timeout) | JY6302.JY6302AITask
ReadRawData(IntPtr EMFBuf, IntPtr coldJunctionTemperatureBuf, int samplesPerChannel, int timeout) | JY6302.JY6302AITask
ReadSinglePoint(ref double[] buf) | JY6302.JY6302AITask
ReadSinglePoint(IntPtr buf) | JY6302.JY6302AITask
Record | JY6302.JY6302AITask
RemoveChannel(int chnID) | JY6302.JY6302AITask
ReportBuildInCJException() | JY6302.JY6302AITask
SampleClock | JY6302.JY6302AITask
SampleRate | JY6302.JY6302AITask
SamplesToAcquire | JY6302.JY6302AITask
SendSoftwareTrigger() | JY6302.JY6302AITask
SetCJTemperature(int chnID, double temperature) | JY6302.JY6302AITask
SetCJTemperature(double[] temperature) | JY6302.JY6302AITask
SignalExport | JY6302.JY6302AITask
Start() | JY6302.JY6302AITask
Stop() | JY6302.JY6302AITask
TransferedSamples | JY6302.JY6302AITask
Trigger | JY6302.JY6302AITask
WaitUntilDone(int timeout=-1) | JY6302.JY6302AITask


6302 C# Programming Manual: Class Index

Class Index
A | J
A
AIAdvanced (JY6302)
AIChannel (JY6302)
AIDigitalTrigger (JY6302)
AIExternalSampleClock (JY6302)
AIRecord (JY6302)
AISampleClock (JY6302)
AISignalExport (JY6302)
AITrigger (JY6302)
J
JY6302AITask (JY6302)


6302 C# Programming Manual: D:/6302 Directory Reference

  • D:
  • 6302
6302 Directory Reference

Directories

directory C#


6302 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 6302


6302 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 6302
▼ C#
AIAdvanced.cs
AIChannel.cs
AIClock.cs
AIRecord.cs
AISignalExport.cs
AITrigger.cs
JY6302AITask.cs


6302 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY6302.AISignalExport
  • AddChannel() : JY6302.JY6302AITask
  • Advanced : JY6302.JY6302AITask
  • AIChannel() : JY6302.AIChannel
  • AvailableSamples : JY6302.JY6302AITask

- b -

  • BuildInCJC : JY6302.JY6302AITask

- c -

  • ChannelID : JY6302.AIChannel
  • Channels : JY6302.JY6302AITask
  • Clear() : JY6302.AISignalExport
  • ClearAll() : JY6302.AISignalExport
  • CustomizedCJTemperature : JY6302.AIChannel

- d -

  • DetectOpenThermocouple() : JY6302.JY6302AITask
  • Device : JY6302.JY6302AITask
  • Digital : JY6302.AITrigger

- e -

  • Edge : JY6302.AIDigitalTrigger
  • ExpectedRate : JY6302.AIExternalSampleClock
  • External : JY6302.AISampleClock

- f -

  • FileFormat : JY6302.AIRecord
  • FilePath : JY6302.AIRecord

- g -

  • GetRecordPreviewData() : JY6302.JY6302AITask
  • GetRecordStatus() : JY6302.JY6302AITask

- j -

  • JY6302AITask() : JY6302.JY6302AITask

- l -

  • Length : JY6302.AIRecord

- m -

  • MaxSampleRate : JY6302.JY6302AITask
  • MaxVoltageRange : JY6302.AIChannel
  • Mode : JY6302.AIRecord , JY6302.AITrigger , JY6302.JY6302AITask

- n -

  • NonTCSignalMeasEnabled : JY6302.JY6302AITask

- p -

  • PowerLineRejection : JY6302.JY6302AITask
  • PreTriggerSamples : JY6302.AITrigger

- r -

  • ReadData() : JY6302.JY6302AITask
  • ReadRawData() : JY6302.JY6302AITask
  • ReadSinglePoint() : JY6302.JY6302AITask
  • Record : JY6302.JY6302AITask
  • RemoveChannel() : JY6302.JY6302AITask
  • ReportBuildInCJException() : JY6302.JY6302AITask
  • ReTriggerCount : JY6302.AITrigger

- s -

  • SampleClock : JY6302.JY6302AITask
  • SampleRate : JY6302.JY6302AITask
  • SamplesToAcquire : JY6302.JY6302AITask
  • SendSoftwareTrigger() : JY6302.JY6302AITask
  • SetCJTemperature() : JY6302.JY6302AITask
  • SignalExport : JY6302.JY6302AITask
  • Source : JY6302.AIDigitalTrigger , JY6302.AISampleClock
  • Start() : JY6302.JY6302AITask
  • Stop() : JY6302.JY6302AITask

- t -

  • Terminal : JY6302.AIExternalSampleClock
  • ThemocoupleType : JY6302.AIChannel
  • TransferedSamples : JY6302.JY6302AITask
  • Trigger : JY6302.JY6302AITask
  • Type : JY6302.AITrigger

- w -

  • WaitUntilDone() : JY6302.JY6302AITask


6302 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JY6302.AISignalExport
  • AddChannel() : JY6302.JY6302AITask
  • AIChannel() : JY6302.AIChannel

- c -

  • Clear() : JY6302.AISignalExport
  • ClearAll() : JY6302.AISignalExport

- d -

  • DetectOpenThermocouple() : JY6302.JY6302AITask

- g -

  • GetRecordPreviewData() : JY6302.JY6302AITask
  • GetRecordStatus() : JY6302.JY6302AITask

- j -

  • JY6302AITask() : JY6302.JY6302AITask

- r -

  • ReadData() : JY6302.JY6302AITask
  • ReadRawData() : JY6302.JY6302AITask
  • ReadSinglePoint() : JY6302.JY6302AITask
  • RemoveChannel() : JY6302.JY6302AITask
  • ReportBuildInCJException() : JY6302.JY6302AITask

- s -

  • SendSoftwareTrigger() : JY6302.JY6302AITask
  • SetCJTemperature() : JY6302.JY6302AITask
  • Start() : JY6302.JY6302AITask
  • Stop() : JY6302.JY6302AITask

- w -

  • WaitUntilDone() : JY6302.JY6302AITask


6302 C# Programming Manual: Class Members - Properties

- a -

  • Advanced : JY6302.JY6302AITask
  • AvailableSamples : JY6302.JY6302AITask

- b -

  • BuildInCJC : JY6302.JY6302AITask

- c -

  • ChannelID : JY6302.AIChannel
  • Channels : JY6302.JY6302AITask
  • CustomizedCJTemperature : JY6302.AIChannel

- d -

  • Device : JY6302.JY6302AITask
  • Digital : JY6302.AITrigger

- e -

  • Edge : JY6302.AIDigitalTrigger
  • ExpectedRate : JY6302.AIExternalSampleClock
  • External : JY6302.AISampleClock

- f -

  • FileFormat : JY6302.AIRecord
  • FilePath : JY6302.AIRecord

- l -

  • Length : JY6302.AIRecord

- m -

  • MaxSampleRate : JY6302.JY6302AITask
  • MaxVoltageRange : JY6302.AIChannel
  • Mode : JY6302.AIRecord , JY6302.AITrigger , JY6302.JY6302AITask

- n -

  • NonTCSignalMeasEnabled : JY6302.JY6302AITask

- p -

  • PowerLineRejection : JY6302.JY6302AITask
  • PreTriggerSamples : JY6302.AITrigger

- r -

  • Record : JY6302.JY6302AITask
  • ReTriggerCount : JY6302.AITrigger

- s -

  • SampleClock : JY6302.JY6302AITask
  • SampleRate : JY6302.JY6302AITask
  • SamplesToAcquire : JY6302.JY6302AITask
  • SignalExport : JY6302.JY6302AITask
  • Source : JY6302.AIDigitalTrigger , JY6302.AISampleClock

- t -

  • Terminal : JY6302.AIExternalSampleClock
  • ThemocoupleType : JY6302.AIChannel
  • TransferedSamples : JY6302.JY6302AITask
  • Trigger : JY6302.JY6302AITask
  • Type : JY6302.AITrigger


6302 C# Programming Manual: Main Page

6302 C# Programming Manual Documentation


6302 C# Programming Manual: JY6302 Namespace Reference

Classes | Enumerations
JY6302 Namespace Reference

Classes

class | AIAdvanced
Analog Input Advance Parameter Class More...
class | AIChannel
AI channel class. More...
class | AISampleClock
Sample clock configuration class More...
class | AIExternalSampleClock
External Sample Clock Configuration Class More...
class | AIRecord
AI Record mode params. More...
class | AISignalExport
AI Signal Export Class More...
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AITrigger
AI Trigger params More...
class | JY6302AITask
JY6302 AI task class which applies to temperature measurements using the Type R/S/B/J/T/E/K/N/C/A thermocouple(max input voltage +-78.125mV). More...

Enumerations

enum class | AISampleClockSource { Internal = JY6302Import.JY6302_InternalSampleClock , External = JY6302Import.JY6302_ExternalSampleClock }
AI Sample Clock Source More...
enum class ClockTerminal {
PFI0 = JY6302Import.JY6302_DigitalTriggerSource_PFI_0 , PFI1 = JY6302Import.JY6302_DigitalTriggerSource_PFI_1 , PFI2 = JY6302Import.JY6302_DigitalTriggerSource_PFI_2 , PFI3 = JY6302Import.JY6302_DigitalTriggerSource_PFI_3 ,
PXI_Trig0 = JY6302Import.JY6302_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY6302Import.JY6302_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY6302Import.JY6302_DigitalTriggerSource_BUS_2 , PXI_Trig3 = JY6302Import.JY6302_DigitalTriggerSource_BUS_3 ,
PXI_Trig4 = JY6302Import.JY6302_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY6302Import.JY6302_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY6302Import.JY6302_DigitalTriggerSource_BUS_6 , PXI_Trig7 = JY6302Import.JY6302_DigitalTriggerSource_BUS_7 ,
PXI_Star = JY6302Import.JY6302_DigitalTriggerSource_STAR
}
Clock Terminal More...
enum class | FileFormat { Bin }
Streaming file format enum type. More...
enum class | RecordMode { Finite , Infinite }
Record mode enum type. More...
enum class | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum class AIDigitalTriggerSource {
PFI0 = JY6302Import.JY6302_DigitalTriggerSource_PFI_0 , PFI1 = JY6302Import.JY6302_DigitalTriggerSource_PFI_1 , PFI2 = JY6302Import.JY6302_DigitalTriggerSource_PFI_2 , PFI3 = JY6302Import.JY6302_DigitalTriggerSource_PFI_3 ,
PXI_Trig0 = JY6302Import.JY6302_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY6302Import.JY6302_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY6302Import.JY6302_DigitalTriggerSource_BUS_2 , PXI_Trig3 = JY6302Import.JY6302_DigitalTriggerSource_BUS_3 ,
PXI_Trig4 = JY6302Import.JY6302_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY6302Import.JY6302_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY6302Import.JY6302_DigitalTriggerSource_BUS_6 , PXI_Trig7 = JY6302Import.JY6302_DigitalTriggerSource_BUS_7 ,
PXI_Star = JY6302Import.JY6302_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | AITriggerType { Immediately = JY6302Import.JY6302_TriggerType_Immediately , Digital = JY6302Import.JY6302_TriggerType_Digital , Soft = JY6302Import.JY6302_TriggerType_Soft }
AI trigger type enum type. More...
enum class | AIDigitalTriggerEdge { Rising = JY6302Import.JY6302_DigitalTriggerEdge_Rising , Falling = JY6302Import.JY6302_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum class | AIMode { Finite = JY6302Import.JY6302_AI_Finite , Continuous = JY6302Import.JY6302_AI_Continuous , Single = JY6302Import.JY6302_AI_Single , Record = 3 }
AI mode enum type. More...
enum class | ThermocoupleConnectionStatus { Normal , OpenCircuit , ShortCircuit }
Thermocouple connection status More...
enum class | BurnoutCurrentValue { _0p5uA = 1 , _2uA = 2 , _4uA = 3 }
Burnout current value selection for open thermocouple detection More...

Enumeration Type Documentation

◆ AIDigitalTriggerEdge

enum JY6302.AIDigitalTriggerEdge
strong

AI digital trigger edge enum type.

Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ AIDigitalTriggerSource

enum JY6302.AIDigitalTriggerSource
strong

AI digital trigger source enum type.

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PXI_Trig0 | PXITrig_0
PXI_Trig1 | PXITrig_1
PXI_Trig2 | PXITrig_2
PXI_Trig3 | PXITrig_3
PXI_Trig4 | PXITrig_4
PXI_Trig5 | PXITrig_5
PXI_Trig6 | PXITrig_6
PXI_Trig7 | PXITrig_7
PXI_Star | PXI STAR

◆ AIMode

enum JY6302.AIMode
strong

AI mode enum type.

Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.
Record | Record mode.

◆ AISampleClockSource

enum JY6302.AISampleClockSource
strong

AI Sample Clock Source

Enumerator
Internal | Internal Clock Source
External | External Clock Source

◆ AITriggerMode

enum JY6302.AITriggerMode
strong

AI trigger mode enum type.

Enumerator
Start | Start trigger
Reference | Reference trigger. Only valid in the Finite mode.

◆ AITriggerType

enum JY6302.AITriggerType
strong

AI trigger type enum type.

Enumerator
Immediately | Immediately, no trigger.
Digital | Digital trigger.
Soft | Software trigger.

◆ BurnoutCurrentValue

enum JY6302.BurnoutCurrentValue
strong

Burnout current value selection for open thermocouple detection

Enumerator
_0p5uA | 0.5uA
_2uA | 2uA
_4uA | 4uA

◆ ClockTerminal

enum JY6302.ClockTerminal
strong

Clock Terminal

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PXI_Trig0 | PXITrig_0
PXI_Trig1 | PXITrig_1
PXI_Trig2 | PXITrig_2
PXI_Trig3 | PXITrig_3
PXI_Trig4 | PXITrig_4
PXI_Trig5 | PXITrig_5
PXI_Trig6 | PXITrig_6
PXI_Trig7 | PXITrig_7
PXI_Star | PXI STAR

◆ FileFormat

enum JY6302.FileFormat
strong

Streaming file format enum type.

Enumerator
Bin

Binary file format

◆ RecordMode

enum JY6302.RecordMode
strong

Record mode enum type.

Enumerator
Finite | Finite mode.
Infinite | Infinite mode.

◆ ThermocoupleConnectionStatus

enum JY6302.ThermocoupleConnectionStatus
strong

Thermocouple connection status

Enumerator
Normal | Normal
OpenCircuit | Open circuit
ShortCircuit | Short circuit


6302 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIDigitalTriggerEdge : JY6302
  • AIDigitalTriggerSource : JY6302
  • AIMode : JY6302
  • AISampleClockSource : JY6302
  • AITriggerMode : JY6302
  • AITriggerType : JY6302
  • BurnoutCurrentValue : JY6302
  • ClockTerminal : JY6302
  • FileFormat : JY6302
  • RecordMode : JY6302
  • ThermocoupleConnectionStatus : JY6302


6302 C# Programming Manual: Package Functions

  • AIDigitalTriggerEdge : JY6302
  • AIDigitalTriggerSource : JY6302
  • AIMode : JY6302
  • AISampleClockSource : JY6302
  • AITriggerMode : JY6302
  • AITriggerType : JY6302
  • BurnoutCurrentValue : JY6302
  • ClockTerminal : JY6302
  • FileFormat : JY6302
  • RecordMode : JY6302
  • ThermocoupleConnectionStatus : JY6302


6302 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY6302 |
C AIAdvanced | Analog Input Advance Parameter Class
C AIChannel | AI channel class
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AIRecord | AI Record mode params
C AISignalExport | AI Signal Export Class
C AIDigitalTrigger | AI Digital trigger params
C AITrigger | AI Trigger params
C JY6302AITask | JY6302 AI task class which applies to temperature measurements using the Type R/S/B/J/T/E/K/N/C/A thermocouple(max input voltage +-78.125mV)